Email Verification Message Sent

Incident Report for US Production Cloud

Resolved

We would like to provide an update regarding the email verification notification that some end users may have unexpectedly received yesterday.

Following a thorough review, we confirmed that the message was triggered unintentionally due to human error. The situation was promptly identified, and corrective actions were implemented to prevent any recurrence.

Importantly, there was no impact on user accounts, personal data integrity, or service availability, and no action is required from customers.

We sincerely regret any confusion this may have caused. Thank you for your continued confidence, collaboration, and trust in Plume
Posted Nov 13, 2025 - 09:01 UTC

Identified

Earlier today, some end users may have received an unexpected email requesting verification of their email address.
This message was sent in error due to a system issue on our side.

The issue was identified and fully resolved shortly after discovery. No customer action is required, and there was no impact to user accounts, personal data, or service functionality.

We apologize for any confusion this may have caused and appreciate your understanding.
Thank you for your continued partnership and trust in Plume.
Posted Nov 12, 2025 - 11:01 UTC