Unexpected Website blocking

Incident Report for US Production Cloud

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 23:45 UTC

Update

Website block issues have been resolved and we are monitoring.
Posted Aug 13, 2026 - 21:35 UTC

Identified

Plume engineering identified the cause of the the issue and are in process of deploying the fix.
Posted Aug 13, 2026 - 21:18 UTC

Investigating

We are currently seeing issues with unexpected websites being blocked by Plume security services. Plume engineering is currently investigating the issue to determine the root cause and mitigation.
Posted Aug 13, 2026 - 20:41 UTC
This incident affected: Misc Services (Guard).